Tag Archives: networking

Linksys E4200 (V1) and an RMA experience

E4200

Two things I noticed about this router (E4200V1):

  1. It gets quite warm under load
  2. When my PC crashes due to overclocking, it usually takes out the router along with it (all clients lose connectivity)

Specifically my combination consisted of the 82579V Intel chipset on my P8Z77-V with a E4200V1.

I came home one day to find my PC offline, and my room having a funky smell described to me by my wife as “man-smell”.  After hunting around, I noticed the E4200 laying on my carpet feeling as if it was going to smolder and start making my carpet go up in flames. Immediately I unplugged it, and blasted it with a few bursts from my compressed gas duster.

Continue reading

Leave a Comment

Filed under computers

Trendnet TEW-687GA Wireless Bridge

So a while ago I purchased a Trendnet TEW-687GA bridge. It has a Gigabit port so that you can hit >10 MB/sec, as other Wireless N bridges only have 10/100 ports on the back.

Trendnet Bridge

Unfortunately I didn’t do my research properly. My Linksys E4200 only has a 2×2 antenna on 2.4 GHz, and 3×3 on 5 GHz. This effectively limits me to a max of 300 Mbps off of the bridge.

Moving on, I upgraded my media server to a Sandy Bridge system with a cheap motherboard. It is a Gigabyte H61M-USB3 and it has an Atheros AR8151 network chip. This thing gave me the biggest headache out of any networking gear I’ve purchased in the last few years.

Continue reading

Leave a Comment

Filed under computers

Linksys AE2500

AE2500 Box

After a wicked sale and an itch to buy a new gadget, I bit the bullet and purchased a 3×3 simultaneous dual band router.  With much deliberation I chose the Linksys E4200.  It is a powerful 2.4/5.0 simultaneous dual band router, with a 3×3 antenna on 5 GHz (2×3 on 2.4 GHz), and is Broadcom based.  This means I can flash it with Tomato!

Experimenting with my TRENDnet 673GRU had me run into a problem with client-bridge (routed) mode in DD-WRT where I could only access LAN and not Internet.  It has something to do with the number of MAC address fields in the packet (three vs four if WDS is used, see the Limitations section here: http://www.dd-wrt.com/wiki/index.php/Wireless_Bridge).  Seeing as WDS between two different chipsets is not recommended, and the fact that the E4200 stock firmware does not support WDS, I had to look for another route.

One strange tidbit: The E4200 with Tomato did not co-operate with my 673GRU w/DD-WRT bridged.  Throughput was great, but for some reason streaming my high bitrate movies was a stuttery slideshow.  On the stock Linksys firmware it was free of problems (besides the client bridge issue I noted above).

I was thinking about purchasing the TrendNET 450 Mbps adapter, either USB (about $50) or Ethernet ($80).  However, I had $35 worth of vouchers that I could use towards a $40 USB adapter that is available at a local big box store.  $10 and change later, I had a Linksys AE2500 USB Wifi adapter in my hands.  It supports 5 GHz, and has a 2×2 antenna design for “300 Mbps”.

The first thing I noticed is that the box is pretty large for a USB adapter.  When I opened it up, I was actually appalled by the amount of excess material used in the packaging.  Take a look below – the card is there to give you a size reference.  It was such a waste that I just had to share.

 

After getting the E4200, I also purchased a T420s with a 3×3 Wifi card.  That thing lets me pull about 15 MB/sec sustained.  Pretty fast, and more than enough for high bitrate movies.  With my 2×2 673GRU bridge, I can pull 9 MB/sec.  With my 1×1 Rosewill 2.4 GHz N USB adapter I can pull about 4 MB/sec.  I would say that Wifi scales pretty well with each added antenna.

This Linksys AE2500 did not disappoint.  I can pull about 9 MB/sec sustained.  No issues with internet routing since it’s no longer a hack, and now my HTPC can stream without any issues.  Install was fast and simple – insert CD, run setup, insert USB adapter, select network, and input wireless password.

Leave a Comment

Filed under computers

The continual Wifi-N struggle

So I’ve received and setup both 673GRU’s using DD-WRT on 5GHz N (Channel 153/40Mhz/Short preamble).  Even with the two routers separated by 1 meter, the signal strength doesn’t report that high in the status screen (only about 60%).   Apparently it’s an issue on DD-WRT, where it under-reports the strength.

I managed to have my routers negotiate a 120 Mbps connection in the short distance from the base router to the client bridge.  It will pull approximately 6 MB/sec peak, but unfortunately still not enough for high bitrate MKVs.  I figure it might have something to do with signal strength, so I did some research.

Later in the same evening, the winds blew in a strange direction and my routers were reporting 0% signal strength, though the connection was still there but resulted in even low bitrate divx having buffering issues.

According to the DD-WRT Wiki, the DIR-825 (basically identical to the 673GRU) has the following specs:

Antenna Gain (2.4 GHz): 2 dBi
Antenna Gain (5 GHz): 2 dBi

Max TX Power (2.4 GHz): 18dBm
Max TX Power (5 GHz): 17dBm

FCC ID: KA2DIR825B1
FCC ID: XU8TEW673GRU

The 673GRU has 3 dBi antennas, so that is one setting you need to change.

Those are the max TX power settings I can set in DD-WRT, however the FCC documentation shows that 5 GHz band can get up to 25.8 dBm as long as you use the higher channels.  The lower channels cap out at 15 dBm.

I need to do some more research and figure out how to unlock the extra antenna power.

Leave a Comment

Filed under computers

Confirmed WNDR3700V1 degradation

My coworker graciously lent me his brand new Realtek 8188 USB bgn wifi adapter so that I could test throughput at speeds >54Mbps.

Results?

WNDR3700-100NAS 01R15 -> 8188 = Link speed of 65 Mbps, ~6 Mbps throughput
TEW-673GRU -> 8188 = Link speed of 65 Mbps, ~49 Mbps throughput

What is interesting to note, the 6 Mbps throughput is what my 673GRU was reporting while bridged to the 3700.I’m hesitant to try flashing my 3700 to DD-WRT as many report radio issues even when flashed back to the Netgear firmware: https://spreadsheets.google.com/pub?key=0As5olSHZWDA7dDhYLTI1WW5HVWxtdUtYdHh5WWhnMUE&hl=de&single=true&gid=0&output=html

I’ve concluded that my Netgear WNDR3700 is no longer suitable, so I purchased another 673GRU.  Hopefully the pair of these will perform well otherwise they’ll make gifts for my family members.

Leave a Comment

Filed under computers

Building A Cheap Wireless N Bridge

Having a blast figuring out  Wireless N bridging.  The idea is to bridge two wireless routers together so that I don’t have to run an ethernet cable to my entertainment area so that my HTPC and Xbox 360 can get on to my LAN with minimal cost.

My setup currently consists of:

  • Netgear WNDR3700 v1 01R15 v1.07.98NA
  • Trendnet TEW-673GRU flashed w/DD-WRT v24-sp2 build 17201

The Netgear I purchased immediately after it was available from launch.  The Trendnet was a recent impulse buy after I discovered you can flash it to DD-WRT.  Both, incidentally, are from Dell days-of-deals (oh how many countless dollars have been spent on those).

The TEW-673GRU is identical to the D-Link DIR-825 router, sporting an Atheros AR7161 680MHz CPU, 8 MB of flash, and 64 MB of RAM.  Pretty impressive specs. In fact, the same as my Netgear which cost twice as much!  After flashing to DD-WRT the LCD on the top is rendered useless.  You will be without port LED indicators, but that’s the least of my concerns.

I first struggled with flashing the 673GRU to DD-WRT.  Little did I know, just flash directly using the modded DIR-825 DD-WRT found here.  I was trying to flash using the recovery mode which just didn’t want to work.  Afterwards, you can upgrade directly to the latest version for the DIR-825.  Make sure to set the Antenna dbi to 3 to match the stock antennas, otherwise your signal quality will be garbage.

Second, follow these instructions for setting up Client Bridge mode.   I struggled here, and was finally able to get it working with WPA-TKIP.  You also have to be patient and wait for it to negotiate.  I found that I had to disable/renable my computer NIC whenever I made changes to the wireless configuration.  It’s renewing the routing table or something, I suppose.

But then I realized, what the heck, why am I only getting 54Mbps throughput on Wireless N 5GHz???  I tried upgraded to the latest WNDR3700 firmware (1.07.98NA), and then realized that you can only select 150 or 300 Mbps using WPA2-AES.

“GREAT!”  I thought.

Flipped everything over, saw my 673GRU negotiate a 300M/300M link.  Excellent.  Ping test to my router results in 1ms response.  So far so good.

Copy a file… and BAM.  RX mode drops to 6 Mbps.  TX stays at around 270-300.

Then I remembered reading about the WNDR3700 antenna issues.  Great.  My device is a 01R15 – one of the original release units.  No wonder my Belkin Wireless N PCMCIA card choked.  I thought it was because it was a cheap $5 clearance item.

Next step, test my 673GRU with the Belkin Wireless N card and see if I can negotiate and sustain a 150 Mbps connection.  If this works, I’ll be picking up another 673GRU.  The value of these things is incredible.  My only wish is that Tomato router firmwares supported Atheros chipsets and not just Broadcom.

Leave a Comment

Filed under computers