Category Archives: computers

nVidia GeForce 310 512MB

Geforce 310 Card

Been toying around with some cheapo nVidia Geforce 310 cards. They’re something to toss in if you just need to output video, with a DisplayPort and VGA ports. It’s also slightly better than the GT210’s that the old Mac Pro models embarrassingly came with.  It’s not noisy, but it’s not silent either.  The non-standard mounting holes doesn’t make it easy for aftermarket cooling either!

After a bit of tinkering and some more searching, I managed to get dual display out of this thing using the following NVCAP:

VGA / DVI-I – BAAAAAAAAQAGAAAAAAAAAAAAAAA=

Here are a couple of other ones that may be of use depending on the configuration of your own card:

DVI-I / DVI-I - BAAAAAAAAwAMAAAAAAAABwAAAAA=
DVI-I / VGA - BAAAAAAAAwAEAAAAAAAABwAAAAA=

(Sourced from: http://www.insanelymac.com/forum/index.php?showtopic=205995)

Using the VGA/DVI-I NVCAP and EFI Studio to generate a string for the 8400GS  512MB (with a bit of tweaking), it now detects perfectly!

Leave a Comment

Filed under computers

XFX Radeon HD6950 Unlocked

Recently been reading about how the Radeon 6950 can be shader unlocked to become a full fledged 6970. Taking advantage of boxing week savings, I managed to snag an XFX 6950 at a nice price. Unfortunately it came on NYE (Happy New Year!) and I didn’t get a chance to play with it until today.

xfx6950-1

I’m upgrading from a non-reference XFX Radeon HD5850 which overclocked like a champ for the one or two months that I owned it.

Following the steps found over at TechPowerUp’s AMD Radeon HD 6950 to HD 6970 Mod page, I proceeded to flash it using the XFX HD6970 BIOS also found on their site.

Look below for lots of pics!








And here we go unlocked!

Make sure to set your PowerTune in CCC up to +20% to unlock the full benefits!

Here is a quick comparison for 5850 vs 6950@6970 in Unigine

Buy up these cards before AMD’s new revision removes this unlock!

Leave a Comment

Filed under computers

10.6.5 Update

I’m a few days behind, but finally got my HackPro 4.1 updated to 10.6.5!

hack-1065-about

My setup is pretty simple, so the only steps required were:

1. Update to 10.6.5
2. Roll back AppleHDA.Kext to 10.6.2 to fix sound and sleep
3. Install i3 update for System Profiler.

I used MultiBeast 2.4.1 for steps 2+3.

Everything’s working well, and I also installed the “Jailbroken” USB3 drivers that Cartri has so kindly hosted.

Recently sold my HD5870, so I’ve switched my main computer over to a HD5770. It works quite nicely using Kabyl’s boot loader. Also purchased a cheap $10 Mini DisplayPort->VGA adapter and it works quite nicely!

Leave a Comment

Filed under computers

HD5870 + OSX + 3 Displays

Finally able to get my Radeon HD5870 1GB working with my HackPro 4.1.

After using netkas’s 5870 hack, a few guys over at InsanelyMac got it working using an ATI ROM and new boot loader.

No more issues with 2560×1600 requiring the display to sleep before it works. Also, all three monitors are working as well! 2 x DVI + 1 x DisplayPort to DVI (using an active adapter).
Steps are as follows (replicated from the InsanelyMac post):

1. Install all kext’s found on netkas’s post, EXCLUDING ATY_init.kext
2. Grab your ATI ROM and stick it in /Extras, naming it properly
3. Install the new boot7 loader
4. Boot with flags UseAtiRom=Yes GraphicsEnabler=Yes

Leave a Comment

Filed under computers

Dell Inspiron 5150 Repair

Someone at work brought in an Inspiron 5150 that had random shutdown issues. I figured I’d take a look and see if it was overheating, however I randomly found out that tapping on the left palm rest would cause it to shut down on demand.

Doing a quick search, I quickly discovered that it was a very common problem.

Thanks to this huge thread, I disassembled and resoldered the culprit and now there are no issues… besides the two extra screws that I now have on my desk.

The thread recommends you using a pin-tip for your soldering iron, but you can use anything that’s decently small. The goal is to only reflow the solder. the chip is under panel C where the wireless card would be, and underneath the black plastic. Sorry, no pictures! I forgot to take them during the repair. Touch each leg for a second and make sure to press down on the leg. Reassemble, power on, tap on the palm rest – no reboot = success!

Leave a Comment

Filed under computers

Dell Inspiron 8200 Video Corruption


What you’re looking at is what I used to fix my Dell Inspiron 8200 corrupt video problem.

Not too long ago I came into possession of a “broken” Dell Inspiron 8200 laptop. Some pretty nice specs – P4 2.2 GHz, 1 GB RAM, 60 GB HDD, 1600×1200 LCD(!), but with a video corruption problem. Every so often it would garble the screen with some snow, or random characters would appear while in the BIOS.

As suggested by one person’s post, I tried cleaning the connector that attaches to the motherboard with some isopropyl alcohol and it did not fix anything. Someone suggested that flexing the bottom right of the motherboard would temporarily solve it.

After some more fiddling, it worked for a while after it had “rested” for 30 minutes or so. Touching the laptop in anyway would bring about a jumbled screen. I concluded that it was overheating and again turned it off, let it cool off, and then turn it back on with a perfectly working display.

Figuring that maybe it was a loose GPU like the recent nVidia problems, I planned to attempt a fix like the Xbox 360 clamp mod.

Using materials from around my computer room… zip ties, DVD spindle spacers, a small piece of velcro, and an NCIX product sticker, I went to work. The results are below….


and it works!!!

Leave a Comment

Filed under computers

montreal

So I was in montreal for a week performing some pc upgrades. This is the first time I’ve laid my hands on the system, so after powering it up and finding that they’re impressively quiet compared to older IBM/Lenovo workstations I decide to pop one open.

Naturally the first thing that draws my attention is the CPU heatsink. I want to know how this thing can be so quiet. The CPU is an “older” E6550 Conroe G0 step chip so it does run relatively cool. Cool enough for Lenovo to tack on an aftermarket fan on top of Intel’s stock cooler! I had a good chuckle as this is a testament to how cheap these machines are both literally and figuratively. At least they replaced the stupid Intel push pins with a bolt-through mount… but that still doesn’t prevent the chip from reaching a comfortably warm 75 C under full load.

Upon completion of the upgrades, the next job was to strip the old computers of valuable parts and junk the rest. Take a look at the inside of these old Thinkcentres.

Damned good timing. If we hadn’t replaced them, they would have started failing pretty soon. At least the Intellistation M Pros were still healthy.

Leave a Comment

Filed under computers

Gigabit Goodness

If you are using Vista, DISABLE MMCSS.

Start -> Run -> Services.msc -> Multimedia Class Scheduler -> Disable

I was trying to figure out why my network transfers were terribly slow — 55 MB/sec write, 15 MB/sec read. This is over a gigabit network with a test RAID0 Windows 2008 Server and a Samsung 1 TB HDD on my Vista X64 workstation. I read about how playing music causes MMCSS to throttle network file transfer speeds and realized this is my problem.

Now I no longer need to close Steam to get 99.93% utilization of a 1 Gbps connection.

Leave a Comment

Filed under computers

Razer DeathAdder


So my order came in from NCIX, and along with a bunch of other goodies, I finally got my Razer DeathAdder. There were a couple reasons why I wanted a new mouse:

1. My current mouse, a Logitech MX510, was old and showing heavy wear. The mouse feet are falling off, the logo and thumb rests are wearing away.
2. The MX510 emits a high pitched squeal due to the IR emitter it uses in the scroll wheel mechanism. I had an MX518 but I opted not to open it up because it experiences the same problem. [Reference]
3. This mouse has 1000 Hz polling for even better response.


This side by side comparison shows that the two mouses are about the same size. Though in my hand, the DeathAdder feels much larger because there is no recessed groove for the thumb. One thing to note, the mouse cable is so wimpy compared to my MX510. Too bad they didn’t follow Logitech and use a braided cable like on the G5/G7 series. The mouse wheel moves very smoothly with less tactile clicks and much less noise than the MX510.

The feet on the DeathAdder leaves much to be desired. They are VERY thin and it feels like the mouse body is scratching on the surface of my desk. The red glow of the optical sensor is also very dim compared to the MX510… the third generation infrared sensor in action.

The curve of the mouse body is enough to make it feel different. There is no feeling of loose mouse buttons like on the MX5xx series, where the plastic body floats over the actual switch mechanism. There is no groove for the thumb, but there are for your index and middle fingers. The smooth thumb rest is a little odd because for some reason I developed a habit of rubbing my thumb to make sure I get a good hold on the mouse. I rest my palm on the mouse, so I have a feeling that the rubberized top (the same material on the thumb/pinky rest of the MX510) is going to wear off very fast.

On the software side of things, it was easy to setup. Plug it in, install the drivers and reboot. I had to drop the Windows sensitivity down to tick 3 with 1800 DPI to get it to have a similar sensitivity to my old MX510. Also I managed to disable the glowing wheel and logo in the drivers. It sounds very hollow when I pick up the mouse and drop it back on the desk, but the weight is about the same as the MX510. The mouse clicks are sharper, and the thumb button clicks are fuller and louder. I wish there was side scrolling. Those are the only complaints I have about the mouse so far.

I have yet to game with it, but I’m sure I’ll get used to it soon. I’m already getting used to the lack of high pitched squeal… it’s so much more comfortable!

2 Comments

Filed under computers

Black Gates have arrived

Thanks to Parts Connexion, I was finally able to complete my X-Fi hotrodding. I replaced the Jamicon capacitor, which are known to deviate significantly from specification over time, with Rubycon Black Gate capacitors. These are among the best electrolytic capacitors available.

Desoldering the old capacitor took forever. With my 45W soldering iron, it took a few minutes to free each leg. With the aid of solder wick, plenty of flux, and a pin, I managed to clean out the hole and push the gigantic legs of the Black Gate through the holes, and get it soldered into place. I spent nearly an hour replacing one capacitor, compared to the 30 minutes I spent replacing the opamp.

I’ve also been building a budget CMoy amplifier. Tomorrow I get to buy a hole puncher so I can mount everything in an Altoids tin.

1 Comment

Filed under computers, electronics